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LIMITATION OF LIABILITY 
 
 THIS PUBLICATION IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER 

EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES 
OF MERCHANTIBILITY, FITNESS FOR ANY PARTICULAR PURPOSE, OR 
NON-INFRINGEMENT OF THE THIRD PARTY’S RIGHT. 

 
 YOU CAN RECOVER FROM THE COMPANY AND ITS SUPPLIERS ONLY DIRECT 

DAMAGES UP TO THE AMOUNT YOU PAID FOR THE SOFTWARE. YOU CANNOT 
RECOVER ANY OTHER DAMAGES, INCLUDING CONSEQUENTIAL, LOST PROFITS, 
SPECIAL, INDIRECT OR INCIDENTAL DAMAGES. 

 
 THIS PUBLICATION COULD INCLUDE TECHNICAL INACCUACIES OR TYPOGRAPHICAL 

ERRORS.  CHANGES ARE ADDED TO THE INFORMATION HEREIN, AT ANY TIME, FOR 
THE IMPROVEMENTS OF THIS PUBLICATION AND/OR THE CORRESPONDING 
PRODUCT(S). 

 
 
 

PRECAUTIONS 
 
 PRODUCT KEYS: The software requires a key to install it.  You are responsible for 

the use of keys assigned to you.  You should not share the keys with third parties. 
 
 You may make one backup copy of the software.  You may use it only to reinstall 

the software. 
 

 Please make a note of your settings and save them.  This will help when you are 
required to change the system configuration, or when unexpected failure or trouble 
occurs. 

 
 Distributing, copying, disassembling, reverse compiling, reverse engineering, and 

also exporting in violation of export laws of the software provided with this product, 
is expressly prohibited. 
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1. Product Overview 
The HEM (HyperElectronicsMappers) for Cloud Monitoring, Control, & Management 
Station, DP-9099/9050/9010, is designed to be installed in a PC for use within a 
surveillance system.  To achieve the highest user-friendliness, this series of 
software are all based on industry-leading Electronics Map infrastructure - 
HyperElectronicsMappers.  With state-of-the-art Electronics Maps, unlimited levels 
of maps which support versatile dynamic map objects, including camera, alarm 
input, alarm output, etc., can be custom-made by the installers or users based on 
different surveillance requirements. HEM connect to device, the device need public 
IP or domain name so that can be connected. HEM and devices need in the same 
Intranet (HEM and device all use Private IP) , or device use Private IP and port 
forwarding to Public IP, or device use Public IP directly. 
 
   

1.1 Features 
Monitor/control all front-end devices in PC stations 
 

 Cloud monitoring, control, and management for virtually unlimited number of 
front-end surveillance devices such as DVRs 

 All the configurations of front-end devices can be saved in Cloud CMS 
 Bi-directional audio capabilities 
 Remote video, audio, and alarm input monitoring 
 Remote alarm output control 
 Remote PTZ control 
 Remote GPS/POS function 
 Remote software upgrade and setup for devices 
 Remote alarm notification 
 
Backup/playback video/audio in PC stations 
 

 Remote playback of recorded video/audio in front-end devices such as devices 
 Backup live/recorded video/audio of front-end devices and FTP server in local 

HDD 
 Play video/audio stored in local HDD 
 Print/snapshot live or recorded video 
 
User-friendly Hyper Electronics Maps 
 

 Open system architecture 
 Custom-made electronics maps for different surveillance requirements 
 Unlimited levels of maps with hyper-links 
 Support versatile dynamic map objects, such as camera, alarm input, alarm 

output, action button, front-end device, and map 
 Simultaneous monitoring/control of different front-end devices in a single map 
 Virtually unlimited number of objects in a map 
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Ease of use 
 

 Multi-lingual support 
 Single device view same as the split window display in Internet Explorer or via 

hyper electronics map 
 Multiple device view via hyper electronics map 
 Single mouse click to view any hyper electronics map 
 Remote alarm notification to display user-defined hyper electronics map 
 Sequential display for user-defined hyper electronics maps and cameras 
 System provided default/sample bitmaps and icons for each object 
 The bitmaps and icons for each object can be tailored by the users 
 Auto-run for user-defined entry map 
 Password protection can be enabled/disabled by the user 
 
Safety and Security 
 

 Protection key to access front-end devices 
 Password to access front-end devices 
 Multi-level password to enter HEM 
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2. Installations 

2.1 System Requirements 
 

It is recommended to install the HEM software using a PC that meets the following 
system requirements.  If you use a PC that does not meet the following system 
requirements, it may cause problems such as slow imaging or the HEM software 
unable to operate. 
 

 PC 
IBM PC/AT compatible. 

 

 CPU 

Intel® Pentium® 4, 1.6 GHz or above. 
 

 OS 

MicroSoft® Windows® 10/8/7. 
 

 Monitor 
1024 x 768 or above. 

 

 Memory (DRAM) 
2048MB or above, at least 2048MB recommended.  The more complicated the 
HEM maps, the more memory required. 

 

 Network Interface 
Ethernet, 10/100/1000 Base-T for LAN, or the other interfaces which can be 
connected to the internet. 

 

 DirectX 

MicroSoft® DirectX® 9.0 or above. 
 

 
Before running HEM software in your PC, please make sure the followings: 
 

1. DirectX® End-User Runtime 9.0 or above has been installed in your PC successfully.  
If not, please logon to http://www.microsoft.com to get the free download of it. 

 

2. Please go to Start → Setup → Control, select Display → Settings, and set the 
Screen Resolution to at least 1024x768 and Color to 32-bit. 

 

3. To have better look-&-feel for the dialogs in your PC, please go to Start → Setup → 
Control, and select Display → Visual Style → Windows XP Style. 

 
  

http://www.microsoft.com/
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2.2 Installations 
Please note that the PC user must have system administrator password for the PC; 
otherwise, the process will fail, and an error dialog will be shown.   
 

To install the HEM software on your PC, please unzip the file that gets from your 
local dealer or contractor, then double-click on Setup.exe. Please follow the 
instructions on the screen to install the software and all the required components 
step by step. Please note that the Product Key (4 X 6 digits) is shown on the HEM CD, 
the external box, or the file in the CD. Besides, the Protection Key must be the same 
as those of all the devices to be accessed by this PC. Please refer to the Protection 
Key in the System Setup of the devices. If the Protection Keys of the devices are not 
the same, please make sure to set them to the same value which is appropriate to 
you. 
 

Note 1: Different PCs cannot share the same Product Key for HEM of formal release, 
except DP-9010. 

 

Note 2: The Protection Key for remote access is checked for DVR software version 
2.10 or above.  For earlier versions, the Protection Key is not checked for 
remote access. 

 

The software will be installed in the default directory “Program Files\Hyper 
Electronics Mappers” or the directory entered by the user.  After installation, the 
following files/directories will be generated: 
 

 HEM.exe 
HEM executable file. 
 

 Setup.dll 
Information file for this HEM. 
 

 device_list 
Device list for this HEM.  The contents will be updated when the device list is 
modified. 
 

 DEFAULT.hem 
Default entry HEM map file for HEM-9010.  If the users don’t want to build their 
own HEM maps, they can just configure the device list, and use this file as the 
entry HEM map to have 1/4/9/16 split window display.. 
 

 Default 
Directory for all the default HEM map files, icons, and background image files. 
 

 System 
Directory for the system information and settings for the connected devices.  
The contents will be updated when the HEM is running.  Please DO NOT save 
any user’s file in this directory. 
 

 Example 
The directory for some useful examples, including some HEM map files, 
background image files, and icons.  Please note that the filename for the entry 
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HEM map of each example is in capital letters. 
 

 Example1 
This example contains some HEM maps with some Camera objects, Device 
objects, and Link objects.  The background image is a 2-D map.  Iconized 
camera objects are added for updated version of HEM.  Please note that 
one of the HEM maps (as shown below) contains 3 non-top-level maps, 
each with 16 Camera objects, 16 Alarm Input objects, 4 Alarm Output 
objects, and 1 Device object.  So, it contains a total of 48 Camera objects, 
48 Alarm Input objects, 12 Alarm Output objects, 3 Device objects, and 
some Link (to top-level map) objects. 
 

 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Example2 
This example contains some HEM maps with some Camera objects, Alarm 
Input objects - Door & Window, Alarm Output objects - light, and Link objects.  
The Link to non-top-level map can be moved around in HEM Running Mode 
by clicking in it (but outside of the video window) and then move the 
mouse cursor.  The background image is a 2-D map. 

 

 Example3 
This example shows a structured diagram and contains some HEM maps with 
some iconized Camera objects, Alarm Input objects, Action objects, and Link 
(to top-level map) objects. 

 

 Example4 
This example contains some HEM maps with some Alarm Input objects, 
Action objects, and Link objects. 
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 Example5 
This example contains some HEM maps with some Camera objects, Device 
objects, and Link objects.  SEQ mode display is added for updated version of 
HEM.  The available HEM maps are listed in the left side of each HEM map 
for ease of access. 

 

 Example6 / Example7 / Example8 
New examples with better look-&-feel. 
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3. HEM Editing Mode 
HEM map is an innovative idea and the kernel of the whole HEM application 
software.  HEM Editing Mode allows the users to build their own HEM maps.  
For each map, the users can set the background image file which may be an 
electronics map or a 2D/3D diagram scanned or drawn by the users.  Besides, 
different types of map objects, including Camera, Alarm input, Alarm output, etc., 
can be inserted in the maps based on different application requirements.  After 
building your own maps, you may monitor and control the devices by opening & 
running those maps for dynamic display.  By building your own HEM maps, you 
may have the dynamic display screens and the user operations all tailored for your 
specific applications. 
 

If the users don’t want to bother to build their own HEM maps, it’s still OK.  The 
users can just configure the device list, use DEFAULT.hem as the entry map, and 
have standard 1/4/9/16 split window display. 
 
Note: If the HEM maps are built by the installer, the installer may need to set some 

files as “Read Only” to avoid those files to be modified by the end users. 
 

To open HEM: First click on your "Start" button.  Once the menu appears, put your 
mouse on the word "Programs".  From here, look through the list of programs to 
find your version of Hyper Electronics Mappers (HEM), and click on it - this will start 
the Hyper Electronics Mappers (HEM) program. 
 
Once the HEM program opens, you will see the screen as shown below. 
 

 

 



 

- 11 - 

3.1 Configure Device List 
Since each object in the HEM maps corresponds to one of the objects of the 
devices, the user needs to configure the device list first. 
 

Note: DP-9010 users may just modify the device properties, and then run the HEM 
map DEFAULT.hem.  Please refer to Chapter 4 for the operations in 
Running Mode. 

 

In HEM program, click on Tools menu, and then select Device → Config, the Device 
List Dialog for this HEM station will be shown as below. 
 
 
 

Please note that the devices for all the examples are already built in the device list.  
If the PC is connected to some devices, the user may modify the IP address, Port 
Number, Username & Password, and then run the HEM maps (Please refer to 
Chapter 4 – HEM Running Mode) in the Examples to get a better understanding of 
HEM. 
 
Following is a brief description for each item: 
 

 Device Name – any meaningful name for the device.  The Device Name is used 
later for the configurations of all the device related objects.  Please note that 
the devices can be grouped together, and “Group” can be edited in Device Edit 
dialog. 

 

 Type – the type of the device. 
 

 Address/QR code – IP address or URL domain name or the QR code for the 
device.  It should be the same as the IP address (for Static IP) or URL (for PPPoE) 
or QR code in Network Setup for the device.  Please consult your network 
administrator, esp. if virtual server is used in your network. 
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 Control Port – the control port for the device.  The default value is 67.  The 
user may need to change it if virtual server is used or its setting in the device 
has been changed. 

 

 Data Port – the data port for the device.  The default value is 68.  The user 
may need to change it if virtual server is used or its setting in the device has 
been changed. 

 

 Video Stream – “Record” – same as recording stream, or “Extra” – extra network 
stream if dual streaming is supported for the device.  The default value is 
“Record”. 

 

 User Name – the login user name for the device.  It must be in the list in 
Password Setup for the device.  Please note that different levels of users have 
different available operations in HEM.  Please refer to Password Setup in the 
manual for the device for the available operations of each level. 

 

 Password – the corresponding password for the login user name for the device. 
 

 Auto Connection – whether the user wants to connect automatically to this 
device when the HEM program is in running mode (even if the currently opened 
HEM maps contain no objects corresponding to this device). 

 

 Connected – whether this PC is connected with the device now (only for 
information in HEM Running Mode). 

 

The operations are as below: 
 

 Add 
Add a device to the device list. Click on 
the Add button, and the Device Dialog 
will be shown as below. 
 

When check the QRCODE checkbox, you 
can directly enter the code scanned by 
the QRCODE. Click Open to select the 
QRCODE image file for connection. 
 

Note: QRCODE image files only support 
that obtained from the DVR/NVR by 
Backup Device function. 
 

When setting the Address to CMS Server, 
please check the CMS Server checkbox. 
 

The items are as described above. The 
Default Directory is used to open/save 
the properties for this device.  Please 
enter those items, and click on OK button 
to save those settings, or Cancel button 
to exit without saving.  Please note that 
the devices can be grouped together, and 
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users can change the group name, add and delete group. 
 

 Modify 
Modify the above-mentioned items of the selected device in the device list.  
Select a device in the device list, and then click on Modify button, and the 
Device Dialog will be shown as above with all the contents filled in. 
 

 Remove 
Select a device in the device list, and then click on Remove button to remove the 
selected device from the device list. 

 

 Properties 
Select a device in the list, and then click on Properties button to modify the 
properties of the selected device.  The Device Properties Dialog is shown as 
below.  All the items in the Tabs are used to setup the device remotely after 
connection, and will be discussed in HEM Running Mode later. 
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3.2 File Operations 
In HEM program, click on File menu, and then select New to new an HEM map or 
Open to open an existing HEM map.  Once the HEM program opens or news an 
HEM map, you will see the screen similar to the one (Example1/TAIWAN.hem) 
shown below. 
 

 
 

After you finish the editing, you may click on File menu, and then select Close to 
close the file, Save to save the file, Save As to save the updated contents to a 
different file, or Print to print the file. 
 
 

System map files 
 

There are some default system map files under the subdirectory Default of the HEM 
program.  Please do not delete them or move them to another directory.  The 
descriptions are as below: 
 

 1Win.hem, 4Win.hem, 9Win.hem, 16Win.hem, 25Win.hem, 36Win.hem, 
49Win.hem, 64Win.hem – default split-window display map files for all the 
devices and multi-split-window map files.  These HEM maps are all top-level 
maps.  After the users are very familiar with the HEM application, they may 
modify the contents to suit their needs.  However, it would be better to make a 
backup copy before modification. 

 

 Player.hem, PTZ.hem – default player panel HEM map file & PTZ panel HEM map 
file.  These HEM maps are all non-top-level maps, and therefore can be shown 
in another map. 
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3.3 Object Operations 
There are six types of map objects in the HEM program, including Camera, Alarm 
input, Alarm output, Device, Action, and Link.  The descriptions are as below:  
(Please note that only Link to non-top-level HEM map can be moved around in 
HEM map in HEM Running Mode.  Please refer to the Examples to get a better 
understanding of all the objects.) 
 

 Camera 
Corresponding to the camera connected to the device.  In Running Mode, if the 
object is not iconized, the video of the camera will be shown in the defined 
rectangle, and the audio, if exists and is enabled and the camera is focus camera, 
will be output to the HEM station.  If the object is iconized, the (motion) status 
of the camera will be shown with the selected image files (motion triggered or 
not).  Please note that there can be at most 32 “not iconized camera” objects 
of the same device in one HEM map. 
 

 Alarm input 
Corresponding to the alarm input connected to the device.  In Running Mode, 
the status of the alarm input will be shown with the selected image files 
(triggered or not). 
 

 Alarm output 
Corresponding to the alarm output connected to the device.  In Running Mode, 
the status of the alarm output will be shown with the selected image files 
(triggered or not), and the user can click on the displayed image icon to control 
the corresponding alarm output from normal to triggered, or from triggered 
back to normal. 
 

 Device 
Corresponding to the device.  In Running Mode, the user can call up the split 
window display of the device when it’s selected. 
 

 Action 
Corresponding to the predefined Action buttons, including PTZ Up, PTZ Down, 
Freeze, Play, Stop, etc.  Please refer to Appendix B for the predefined Action 
buttons.  In Running Mode, the user can trigger the action by clicking on the 
displayed image icon. 
 

 Link (to another HEM map) 
Corresponding to Link to HEM map.  In Running Mode, the contents of a 
non-top-level HEM map linked will be displayed and can be moved around in its 
parent map.  For a top-level map link (and only link allowed), the user can 
switch to its map display by clicking on its displayed icon.  (This is similar to the 
Hyper-link in web page.)  That is to say, the user can use non-top-level HEM 
map as grouping purpose, and top-level map as (hyper) link purpose. 
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Add An Object 
 

In HEM program, click on Object menu, and then select Camera, Alarm input, Alarm 
output, Device, Action, or Link, for the type of objects to be added to the HEM map.  
The selected object type will be checked. 
 

After the desired object type is selected, click and drag the cursor in the client area 
to add an object to the HEM map.  The object is shown as a rectangle with the 
selected border width and color.  You may repeat this procedure to add as many 
objects as you want. 
 
 

Object Properties 
 

To select and highlight an object in the HEM map, click on Object menu, and then 
select “Select object“.  Now, you may click on any object in the map to select and 
highlight it. 
 

Once an object is selected, you may click on 
Object menu, and then select Border to 
change its border width and color, or select 
Properties to change its properties other than 
border.  The dialogs are as shown. 
 

 
The detailed properties of 
each object type are 
described as below: 
 

 Object type 
The type of this object. 

 

 Top level 
Top level or not.  This is 
only used for HEM map 
file.  Please note that 
non-top-level HEM maps, 
EX. Player.hem or 
PTZ.hem, are very useful 
to group objects together 
to show/move in another 
HEM map. 

 

 Device 
The device name (EX. 
DVR1) for this object.  Please refer to Section 3.1 to configure the device list for 
this station.  “Auto” means that the object is dynamically linked to the 
selected device in Running Mode. 
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 ID 
The ID for this object, EX. the ID for camera 1 is 1 and the ID for alarm input 1 is 
also 1.  For Camera object, the ID can be set as SEQ to make this object capable 
of SEQ mode display in Running Mode.  If so, the user can click on Settings 
button to call up the SEQ Mode Settings dialog as shown below. 
 

 SEQ Mode Settings 
Please select the Camera ID and 
Dwell Time (5~240 seconds), and 
then click on Append button to 
append the settings to the list 
below, Insert button to insert the 
settings right before the 
highlighted item in the list, 
Modify button to modify the 
settings of the highlighted item, 
or Delete button to delete the 
highlighted item.  Please click 
on OK button to exit and save 
the settings, or Cancel button to 
cancel. 

 

 X 
The X-coordinate of this object in the map. 

 

 Y 
The Y-coordinate of this object in the map. 

 

 Width 
The width of this object in the map, or that of the HEM map file. 

 

 Height 
The height of this object in the map, or that of the HEM map file. 

 

 Video/Icon 
(Video, Icon, Video/Icon, Icon/Video).  This is only used for Camera object.  
“Video” means to display the camera video in Running Mode, “Icon” means to 
display the motion status bitmaps of the camera in Running Mode, “Video/Icon” 
and “Icon/Video” mean that the user can switch between Video and Icon in 
Running Mode, with the type before “/” used as default. 

 

 Icon at 
(Upper left, Upper right, Lower left, Lower right) – the corner in the rectangle the 
icon will be displayed in Running Mode. 

 

 Playback 
Playback or not.  This is only used for Camera object for live/playback mode of 
the camera in Running Mode. 
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 Action Type 
One of the predefined Action buttons.  This is used for object type of Action.  
The predefined Action buttons are divided into several groups.  Please refer to 
Appendix B for their descriptions. 
 

 Toggle – information only 
Toggle or not, used for object type of Action.    For non-Toggle type (Icon) of 
Action button, the Action button will always return to non-triggered state after 
the mouse button is released.  For Toggle type (Icon), the Action button will 
keep at the same state after the mouse button is released. 

 

 Image File 
The default image (.BMP or .JPG) file of this object to be shown in the map.  If 
no object is selected, this image file is to be shown as the background image of 
this HEM map. 

 

 Image File - Triggered 
The image (.BMP or .JPG) file of this object to be shown in the map while it’s 
triggered.  This is used for object type of Camera (Icon), Alarm input, Alarm 
output, Action, and Link (to top-level map). 

 

 Map File 
The HEM map file of this object if it’s a Link (to HEM map). 

 

 PTZ Panel File 
The PTZ panel file to be called up for this HEM map in Running Mode.  Please 
note that the PTZ panel file can be changed to a different file for each HEM map. 

 

 Player Panel File 
The Player panel file to be called up for this HEM map in Running Mode.  Please 
note that the Player panel file can be changed to a different file for each HEM 
map. 

 
 

Edit Menu 
 

The user may click on Edit menu to Cut/Copy the selected object, Paste the 
cut/copied object, or Delete the selected object. 
 
 

Context Menu 
 

The user may also use the Context Menu by right clicking on the client area of the 
map.  If there is an object under the cursor, the Context Menu for that object will 
be shown, if there is no object under the cursor, the Context Menu for this HEM 
map file will be shown.  Please refer to the above-mentioned for the menu items 
in the Context menu. 
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3.4 Options 
Click on Tools menu, and then select Options, the Options Dialog will be shown as 
below.  After all the settings are done, please click on OK button to exit and save 
the settings, Apply button to save the settings without exit, or Cancel button to 
cancel. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3.4.1 Auto Run 
The user may select Disable to disable Auto Run, or Device, HEM Map, or SEQ Mode 
/ Maps to enable Auto Run.  If enabled, one of the HEM maps or the devices, or 
SEQ Mode will be Auto Run every time the program starts.  This is to be used as 
the entry point for the user.  If it’s a device, please select the device and its 
split-window display to be shown after Auto Run.  If it’s an HEM map, please select 
the top-level HEM map file to be shown after Auto Run.  Non-top-level HEM map 
should not be selected for auto run.  If SEQ Mode / Maps is selected, please do the 
SEQ Mode / Maps settings as described below. 
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3.4.2 SEQ Mode / Maps 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
SEQ Mode / Maps is used to display the selected HEM maps in the HEM Map File list 
at preset dwell time sequentially in Running Mode. 
 
Please select the top-level HEM Map and Dwell Time (5~240 seconds), and then click 
on Append button to append the settings to the list below, Insert button to insert 
the settings right before the highlighted item in the list, Modify button to modify the 
settings of the highlighted item, or Delete button to delete the highlighted item. 
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3.4.3 Alarm Notification 
 

 
 

Alarm Notification is used to define how HEM responds to the alarms reported from 
the front-end devices in Running Mode. 
 

Please do the settings in Event Information, and then click on Append button to 
append the settings to the list below, Insert button to insert the settings right before 
the highlighted item in the list, Modify button to modify the settings of the 
highlighted item, or Delete button to delete the highlighted item. 
 

Following is a brief description for each item: 
 

 Device, Event Type, Source ID – to define the source of the alarm to call up the 
HEM Map and Action described below. 

 

 HEM Map – to define the top-level HEM Map to be called up when the defined 
alarm is detected. 

 

 Action  →  Device, Alarm Output – to define which Alarm Output of which 
Device will be triggered when the defined alarm is detected. 

 

 Action  →  Show Message, Buzzer – to display the alarm message on the 
screen of the HEM or not, and to activate the internal Buzzer of the PC or not, 
when the defined alarm is detected. 

 

 Action  →  Interval – to define the interval for the Buzzer to keep being 
triggered after the defined alarm is detected. 
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3.4.4 Security 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The system allows virtually unlimited number of user accounts.  There are two 
password levels in the system, including Administrator (highest) and Operator 
(lowest).  The Operator can only operate in Running Mode, but cannot change the 
configurations.  The Administrator can do everything in Editing Mode and Running 
Mode. 
 
The user (administrator) may enable password protection for the HEM program.  If 
the password protection is enabled, the Login Dialog for the HEM program will be 
shown every time the HEM program starts.  Please enter the Login Name, Password, 
Level, and Default Login, and then click on Add button to add the settings to the list 
below, Modify button to modify the settings of the highlighted item in the list, or 
Delete button to delete the highlighted item. 
 
If Default Login is checked for the login name/password, this login name/password 
will be the default one each time the login dialog is shown, so the user doesn’t 
bother to enter the login name/password to login the system. 
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3.4.5 System 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 
The system will automatically detect the language of the Windows system.  If the 
user wants to use a different language, please disable “Auto Detection”, and select 
the desired language. 
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3.4.6 Google Maps 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 
 
 
 
 
The API key paid for Google Maps can be set here.  If users do not have API key, the 
query times for address and the load times of map for all users will be limited to 900 
times per day totally for the built-in vendor provided API key after Jun. 11, 2018.  
 
If users want to have their own OEM API key, please check the following Google 
Cloud Platform documents, including 
. user guide : https://cloud.google.com/maps-platform/user-guide/ , 
. price sheet : https://cloud.google.com/maps-platform/pricing/sheet/ , and 
. pricing changes :  

https://cloud.google.com/maps-platform/user-guide/pricing-changes/ . 
 
If users want to have their own OEM API key, please refer to 
https://console.cloud.google.com and the following screens to new a project for API 
key and set the quota. 
 

https://cloud.google.com/maps-platform/user-guide/
https://cloud.google.com/maps-platform/pricing/sheet/
https://cloud.google.com/maps-platform/user-guide/pricing-changes/
https://console.cloud.google.com/
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If users have their own OEM API key, the query times will be limited to the daily 
quota set (please refer to the screen below). Please set the below-mentioned items 
to 900 times per day so there’s still not any fee charged for the OEM API key. Please 
note that out-of-limit query would fail after Jun. 11, 2018. Besides, if a higher limit is 
set, there would be charge for the extra access. 
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4. HEM Running Mode 
The HEM application software can access the devices remotely if the PC and the 
devices are connected via network, either internet or intranet. 
 
 

Before Running 
 
Before accessing the devices through HEM application software, please make sure 
the followings: 
 
1. The devices are connected to the network and the configurations are all setup 

correctly.  (If the system resources - DRAM, CPU speed, etc. - in the PC are 
limited, or the network bandwidth is low, please set the record resolution of the 
devices to Half-D1 or CIF.) 

 

2. DirectX® End-User Runtime 9.0 or above has been installed in your PC successfully.  
If not, please logon to http://www.microsoft.com to get the free download of it. 

 
3. Port 67 (control port) or port 68 (data port) for the devices is not blocked out by 

your router or ISP (Internet Service Provider). 
 
4. Please go to Start → Setup → Control, select Display → Settings, and set the 

Screen Resolution to at least 1024x768 and Color to 32-bit. 
 
5. To have better look-&-feel for the HEM program in your PC, please go to Start → 

Setup → Control, and select Display → Visual Style → Windows XP Style. 
 
 

Run 
 
To run HEM map: Just run the HEM program if Auto Run for top-level HEM map or 
device, or SEQ Mode / Map is set.  Or click on File menu, and then select Run if the 
top-level HEM map has been opened already.  The screen will be shown similar to 
the one (Example2/BILL’S HOME.hem) below. 
 

http://www.microsoft.com/
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Once the HEM is in Running Mode, the corresponding menu will all be enabled.  
(Please note that “.L” following the camera title stands for Live display, “.P” for 
Playback, and the camera title with white background has detected motion.) 
 
Note: DP-9010 users may use the HEM map DEFAULT.hem as the entry map.  

Please click on the device icon to switch to its split-window display. 
 
 

File Operations 
 
The File Operations are the same as in Editing Mode.  If the HEM map is in Running 
Mode, you may click on File menu, and then select Run to stop running and return 
to Editing Mode, and vice versa.  Please note that the oldest HEM map files may be 
automatically closed if the HEM program consumes too much system memory. 
 
 

Search Operations 
 
There are different search operations, including Time, Event, and PC Video.  Those 
operations are the same as in the Remote Access described in the manual come with 
the device, and are also described below: 
 
 Search By Time 

Click on Search menu, and then select Time to call up Search-by-time Dialog.  
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Please select the time (Year, Month, Date, Hour, and Minute) and recorded 
video/audio type (Alarm, Motion, Video Loss, and Normal) to search for playback.  
Click on Search button to start the search of the recorded video/audio.  (If it 
failed, the result will be shown on the title of the dialog.)  Now, you may use 
the player operations to play the recorded video/audio.  Please note that the 
cameras of different devices can be selected for search by time.  If there’s not 
any camera in playback mode, all cameras will be searched and played.  For 
software V5.45 or above, a playback slider will be shown at playback for 
“Search By Time”. 
 

 
 
The operations are similar to device’s local operations, except that the user 
may click on the bottom area of the playback slider to drag it to a different 
location in the HEM map. 
 

 Search By Event 
Click on Search menu, and then select Event to call up Search-by-event Dialog.  
The event logs will be shown on the screen.  Please select the device, event 
type and source ID to search for the event logs.  Click on Refresh, Up, or Down 
to update the event logs.  Click on the desired event log to highlight and select 
it.  Click on the OK button to search the recorded video/audio for the 
highlighted event log.  Now, you may use the player operations to play the 
recorded video/audio. 

 
 Search PC Video 

Click on Search menu, and then select PC Video to call up Search-PC-video 
Dialog.  Please select the file, and then click on Open.  Now, you may use the 
player operations to play the recorded video/audio in the file. 

 
 POS Search 

Click on Search menu, and then select POS to call up POS-Search Dialog.  
Please select the device, camera, key word, and start/end time, and click on 
“Search”, then the matched POS data will be shown.  Please select the desired 
POS data, and click on “Backup” or “Play” to backup or play the recorded 
video/audio corresponding to the POS data. 

 
 

Player Operations 
 
The Player Operations are the same as in the Remote Access described in the 
manual come with the device.  Those operations include Fast Backward, Fast 
Forward, Single Step, Play, Pause, Stop, and Copy.  Please note that the Copy 
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function can be used to archive both live and playback streams.  The user may use 
the menu, the toolbar, or call up Player Panel for player operations.  Please 
check/uncheck the cameras to be archived when the Copy Dialog is shown, and then 
click on OK or Apply button.  If the user click on Apply button and select & highlight 
one of the cameras, the current copying status for that camera will be shown in the 
dialog. 
 
 

PTZ Operations 
 
The PTZ Operations are the same as in the Remote Access described in the manual 
come with the device.  The user may use the menu or call up PTZ Panel for PTZ 
operations. 
 
 

View Operations 
 
 Toolbar 
Show/hide the Toolbar above the client area. 
 
 Status Bar 
Show/hide the Status Bar below the client area. 
 
 Player Panel 
Show/hide the Player Panel in this HEM map.  Please note that the Player panel file 
is specified in the object properties for this HEM map, and can be changed to a 
different file for each HEM map.  The operations of the default Player Panel are 
similar to those of the Remote Access described in the manual come with the device.  
The user can click on the Player Panel (but outside of any object in it) (to call up the 
Context menu) to move it. 
 
 PTZ Panel 
Show/hide the PTZ Panel in this HEM map.  Please note that the PTZ panel file is 
specified in the object properties for this HEM map, and can be changed to a 
different file for each HEM map.  The operations of the default PTZ Panel are 
similar to those of the Remote Access described in the manual come with the device.  
The user can click on the PTZ Panel (but outside of any object in it) (to call up the 
Context menu) to move it. 
 
 1-W, 4-W, 9-W, 16-W 
Switch to 1-W, 4-W, 9-W, or 16-W split window display of the selected Device object.  
The default split-window display map files in the directory Default will be used.  
The advanced users may edit those default maps to suit their own requirements.  
However, it would be better to make a backup copy before modification. 
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 Playback, Freeze, Audio In / Out / Broadcast 
These View Operations are similar to the Remote Access described in the manual 
come with the device except that the operations for Playback/Freeze apply to the 
whole HEM map.  Please refer to Appendix B for the detailed descriptions. 
 
 SEQ Mode / Cameras 
Switch all the camera objects (in this HEM map) with SEQ settings to SEQ mode, or 
back from SEQ mode. 
 
 SEQ Mode / Maps 
Switch the HEM program to SEQ mode for HEM maps, or back from SEQ mode. 
 
 Google Maps 
Call up Google Maps in this HEM map. Left-clicking the marker to display the address, 
and right-clicking the marker to display the video. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 GPS Display 
Display the GPS information (if any) for all the connected devices in this HEM map. 
 
 G Sensor Trend Chart 
Display G sensor trend chart if the selected device is a mobile device. 
 
 POS Display 
Display the POS information (if any) for all the connected devices in this HEM map. 
 
 Display Control 
Display this HEM map at Original Map Size, to Fit Window, or to Fit Width/Height. 
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 Transform 
Used to mirror, flip, or rotate 180 degrees for the video. 
 
 Digital Zoom 
Used to zoom in the video. While enabled, click in the video for 2X, then 4X, and 
right click to back to 1X. 
 
 

Object Operations 
 
The enabled Object Operations are similar to the Remote Access described in the 
manual come with the device, and the operation applies to the selected object.  
The detailed operations for each object are described below: 
 
 Camera 

If the object is not iconized, the video of the camera will be shown in the 
rectangle, and the audio, if exists and is enabled and the camera is focus camera, 
will be output to the HEM station.  If the object is iconized, the motion status of 
the camera will be shown with the selected image files. 
 
If not iconized, left-click the mouse to select it, or right-click the mouse to call up 
the dialog to change its ID or live/playback status.  The user may also set its 
Playback mode, (un)Freeze the video, Print the video, Snapshot the video, 
display GPS information, configure GPS, display POS information, or configure 
POS  by selecting Object → Playback/Freeze/Print/Snapshot/GPS Display/GPS 
Config/POS Display/POS Config.  If iconized, left-click the mouse to change the 
ID of the previously selected camera object to the ID of this iconized camera 
object. 
 
For Dual mode (Video/Icon or Icon/Video) camera object, the user may double 
click the mouse to switch its display mode back and forth.  For camera object 
with SEQ settings, the user may switch the camera object to SEQ mode, or back 
from SEQ mode by selecting Object → SEQ Mode. 
 

 Alarm input 
The status of the alarm input will be shown with the selected image files.  It’s 
always iconized, and no operation in Running Mode. 
 

 Alarm output 
The status of the alarm output will be shown with the selected image files.  It’s 
always iconized, and the user can left-click on it to control the corresponding 
alarm output from normal to triggered, or from triggered back to normal. 
 

 Device 
Always iconized.  The user can left-click on it to select it.  While it’s selected, 
the user can click on View menu, and then select 1-W, 4-W, 9-W, or 16-W to 
switch to the split-window display of the device.  The user may also click on the 
device, and then select 1-W, 4-W, 9-W, or 16-W to switch to the split-window 
display of the device. 
 

 Action 
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Always iconized.  The user can left-click on it to trigger the corresponding action.  
Please refer to Appendix B for the predefined action buttons and their 
descriptions. 
 

 Link (to another HEM map) 
If it’s a (hyper) Link to a top-level HEM map, it will always be iconized, and the 
user can left-click on it to switch to its map display.  Please note that the oldest 
HEM map files may be automatically closed if the HEM program consumes too 
much system memory.  If it’s a Link to a non-top-level HEM map, it will always 
be not iconized, and the user can click on it (but outside of any object in it) (to 
call up the Context menu) to move it. 
 

 
Backup Operations 

 
Click on Tools menu, and then select Backup to call up Backup Dialog.  Please 
select the device, cameras, event type, destination directory, execution time, and 
data range, and then click on “Apply” or “OK” to backup, or “Cancel” to cancel.  
Please note that Execution of “Now” or “Once” is one-time backup, while “Daily” is 
daily backup. 
 
 

4.1 Device Operations 
In HEM program, click on Tools menu, and then select Device.  The operations are 
as below: 

 
 Connect 

Connect to the devices in the device list.  (The dialog as shown below)  The 
user may select one (or none) of the split-window displays to be invoked and run 
at connection. 
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 Disconnect 
Disconnect from the connected devices.  (The dialog similar as shown above) 

 
 Config 

Please refer to Section 3.1 for the dialogs and operations to configure the 
devices.  All the items in the Device Properties are used to setup the device 
remotely after connection.  Please refer to the Remote Access described in the 
manual come with the device.  Please also refer to the setup of the device in 
the manual come with the device for the detailed descriptions.  Besides, the 
user can download/upload the configurations from/to the connected device, or 
open/save the configurations from/to the designated directory. 

 
 
 Software Upgrade 

Upgrade the devices in the connected device list.  (The dialog as shown below)  
The user may select one (or all) of the devices to be software upgraded, select 
the upgrade file in the PC, and then click on Start button to start the software 
upgrade process.  The Upgrade status will be updated according to the progress.  
When the upgrade file is uploading, the user may click on Stop/Close button to 
stop the upgrade process. 

 
After the software in the device is upgraded, the device will restart immediately 
and the HEM program will be disconnected from the device.  Please (re-run the 
HEM program to) connect to the device(s) again. 
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4.2 Default Screen Operations 
 

 
 
The video images can be displayed in several types of split-window screens, 
including 1/4/9/16/25/36/49/64 for DVRs. And the focus window is surrounded by a 
frame border. In addition to the video windows, there are different icons on the 
lower corner and the right corner of the screen for status display and control. (The 
“.L” following the camera title stands for Live display, “.P” for Playback, and the 
camera title with white background has detected motion.) 
 

Note 1: The frame rate is limited by the bandwidth of the network and the 
pre-record IPS of the camera. 

 

Note 2: The picture quality depends on the recording resolution and recording 
quality of the camera. 

 
When the user leaves HEM, he/she may be asked to save changes to files, please 
enter the directory name (or use default if only one profile is needed), click on OK or 
Yes to save the changes. The operations and descriptions for these icons are as 
below: 
 

In video window, right-click the mouse button to call up Camera/Playback/Print 
Dialog.  (Left) click on Playback or Camera number to change the window to the 
corresponding camera and live/playback mode.  The user may click on the “Print” 
button to print the video to the printer, or “Snapshot” the video.  The user may 
also double click for 1-Window display. 
 

 
 

Click on these icons for 1/4/9/16/25/36/49/64-Window display.  For 4/9 split 
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windows, the user can click on the icon, and select a different display page. 
 

 
 

Click on this icon to switch to or return from SEQ display mode. 
 

 
 

Click on this icon to toggle between live mode and playback mode for all the video 
windows. 
 

 
 

Click on this icon to freeze/unfreeze the video images for all the video windows. 
 

 
 

Click on this icon to enable/mute the audio input from the PC, button down for 
enable, button up for mute. If enabled, the audio input from the PC will be sent to 
the DVR. The default setting is ‘mute’. 
 

 
 

Click on this icon to enable/mute the audio output from the camera for the focus 
window (or DVR), button down for enable, button up for mute. 
 

 
 

Click on this icon to show/hide the GPS data for (1) the selected DVR, or (2) the DVR 
for the focus camera, button down to show, button up to hide. 
 

 
 

Click on this icon to show/hide the POS data (for 9-split-window or larger video 
window) for (1) the selected DVR, or (2) the DVR for the focus camera, button down 
to show, button up to hide. 
 

 
 

Click on this icon mirror, flip, or rotate 180 degrees for the video. 
 

 
 

Click on this icon to backup video/audio, and the Backup dialog will be shown.  
Please select the DVR, cameras, event type, destination directory, execution time, 
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and data range, and then click on “Apply” or “OK” to backup, or “Cancel” to cancel.  
Please note that Execution of “Now” or “Once” is one-time backup, while “Daily” is 
daily backup. 
 

 
 

Click on this icon for snapshot of the focus camera. 
 

 
 

Click on this icon for audio broadcasting to all connected DVRs. 
 

 
 

Click on this icon to toggle between full screen display and normal IE display. 
 

 
 

Click on this icon for full video display (without any icon). 
 

 
 

Click on this icon for Google Map display. 
 

 
 

Click on this icon for G Sensor Trend Chart display. 
 

 
 

Click on these icons to switch the video aspect ratio between 4:3 and 16:9. 
 

 
 

Click on this icon to zoom in the video. While enabled, click in the video for 2X, then 
4X, and right click to back to 1X. 
 

 
 

The device name of the selected DVR is shown.  Click on this icon, and the 
available DVRs will all be shown.  The user may type alphanumeric characters to 
get the matched DVRs.  Click on one of them to select a new DVR.  The 1/4/9/16 
split-window video display, the camera status, and the alarm input/output will all 
switch to correspond to the newly selected DVR.  There’s “Multiple” in the device 
list, the user can select it to display camera video from different DVRs in 4/9/16 split 
window display. 
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Playback panel for playback buttons, including Fast Backward, Fast Forward, Single 
Step, Play, Pause, Stop, and Copy (from left to right).  Please note that the Copy 
function can be used to archive both live and playback streams.  Please 
check/uncheck the cameras to be archived when the Copy Dialog is shown, and then 
click on OK or Apply button.  If the user click on Apply button and select & highlight 
one of the cameras, the current copying status for that camera will be shown in the 
dialog.  
 

 
 

PTZ control panel.  If the camera in the focus window is a PTZ camera, these 
buttons in the PTZ control panel can be used for PTZ control.  The operations 
include Tilt Up/Down, Pan Left/Right, Zoom In/Out, Focus Near, Focus Far, Iris – 
(darker), Iris + (brighter). 
 
Camera /  
 

Status indicators for cameras 1-8/4 (GREEN for normal, RED for motion) for the 
selected DVR.  Click on any of these icons to select the corresponding camera of 
the selected DVR to be displayed in the focus window. 
 
Alarm In /  
 

Status indicators for alarm inputs 1-8 (GREEN for normal, RED for alarm) for the 
selected DVR. 
 
Alarm Out /  
 

Alarm outputs 1-2 (GREEN for normal state, RED for triggered state) for the selected 
DVR.  For Administrator, click on any of these icons to control the corresponding 
alarm output from normal to triggered, or from triggered back to normal. 
 

 
 

Click on this icon to call up Search-by-time dialog.  Please select the time (Year, 
Month, Date, Hour, and Minute) and recorded video/audio type (Alarm, Motion, 
Video Loss, and Normal) to search for playback.  Click on Search button to start the 
search of the recorded video/audio.  (If it failed, the result will be shown on the 
title of the dialog.)  Now, you may use the playback buttons to play the recorded 
video/audio.  If there’s not any camera in playback mode, all cameras will be 



 

- 38 - 

searched and played.  
 

 
 

The operations are similar to DVR local operations, except that the user may click 
on the bottom area of the playback slider to drag it to a different location. 
 

 
 

Click on this icon to call up Search-by-event dialog.  The event logs will be shown on 
the screen.  Please select the DVR device, event type, and source ID to search for 
the event logs.  Click on Refresh, Up, or Down to update the event logs.  Click on 
the desired event log to highlight and select it.  Click on the OK button to search 
the recorded video/audio for the highlighted event log.  Now, you may use the 
playback buttons to play the recorded video/audio. 
 

 
 

Click on this icon to call up search-PC-video dialog.  Please select the file(s), and 
then click on Open.  Now, you may use the playback buttons to play the recorded 
video/audio in the file(s). 
 

 
 

Click on this icon to call up POS-Search dialog.  Please select the DVR, camera, key 
word, and start/end time, and click on “Search”, then the matched POS data will be 
shown.  Please select the desired POS data, and click on “Backup” or “Play” to 
backup or play the recorded video/audio corresponding to the POS data. 
 

 
 

Click on this icon to show/hide full PTZ control panel.  The user can click on the PTZ 
Panel (but outside of any object in it) (to call up the Context menu) to move it. 
 

 
 

Click on this icon to call up Setup dialog.  Unlimited number of DVRs can be added 
to the device list.   
 
Following is a brief description for each item: 
 

 Device Name – any meaningful name for the (DVR) device. 
 

 Address – IP address or URL domain name for the (DVR) device.  It should be 
the same as the IP address (for Static IP) or URL (for PPPoE) in Network Setup for 
the (DVR) device. 
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 Control Port – the control port for the (DVR) device.  The default value is 67. 
 

 Data Port – the data port for the (DVR) device.  The default value is 68. 
 

 Video Stream – “Record” – live video same as recording stream, or “Extra” – 
extra network stream if dual streaming is supported for the (DVR) device.  The 
default value is “Record”. 

 

 User Name – the login user name for the (DVR) device.  It must be in the list in 
Password Setup for the (DVR) device.  Please note that different levels of users 
have different available operations. 

 

 Password – the corresponding password for the login user name for the (DVR) 
device. 

 

 Auto Connection – whether the user wants to connect automatically to this (DVR) 
device. 

 

 Connected – whether this PC is connected with the (DVR) device now.  If a DVR 
is connected, the user may select it, and click on “Reboot” to reboot it. 

 
The user can download/upload the configurations from/to the connected DVR, or 
open/save the configurations from/to the designated directory. 
 

 
 

Click on this icon to call up remote Software Upgrade dialog. The current software 
version of the DVR(s) will be shown in the “status” field. Please select the DVR 
device and upgrade file in the PC, and then click on Start button to start the software 
upgrade process. The Upgrade status will be updated according to the progress.  
When the upgrade file is uploading, the user may click on Stop/Close button to stop 
the upgrade process. After the software in the DVR is upgraded, the DVR will restart 
immediately and the PC will be disconnected from the DVR. 
 
Note: There must be at least one formatted HDD in the DVR for the remote 
upgrade to succeed.  
 

 
 

Click on this icon to call up GPS Configuration dialog. Please select the DVR device.  
Then select Display attributes and Output attributes for Live & Playback 
respectively. The display attributes can set whether Google Map displays GPS 
information, GPS speed, change the color of GPS text, POS display position... etc. If 
Data Exchange File is enabled, the corresponding GPS data will be output to the file 
specified. Please note that Tag and Icon are to be used by GPS software such as 
Google Earth for display purpose. If the Route is checked, the output data exchange 
file will contain the route information. If COM Port is enabled, the corresponding 
GPS data will be output through the specified COM port of the PC.  The output data 
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can be used as input by GPS application software such as Google Earth. 
 

 
 

Click on this icon to call up POS Configuration dialog.  Please select the DVR device.  
Then select Video Window or Pop-up Window to show the POS data.  All the other 
attributes are similar to those for the DVR. 
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Appendix A – Specifications 
 
 HEM (HyperElectronicsMappers) CMS Server 

Feature\Model DP9010 DP9050 DP9099 DP9199 

Monitoring & Control     

Max. # of front-end devices 10 50 Unlimited Unlimited 

Bi-directional audio Yes Yes Yes Yes 

Remote video, audio, alarm 
input/output monitoring 

Yes Yes Yes Yes 

Remote alarm output control Yes Yes Yes Yes 

Remote PTZ control Yes Yes Yes Yes 

Remote upgrade Yes Yes Yes Yes 

Remote configuration Yes Yes Yes Yes 

Remote alarm notification Yes Yes Yes Yes 

Remote playback Yes Yes Yes Yes 

Playback search Date/time, Camera, Alarm, Motion, and POS 

Backup video/audio in HDD Yes Yes Yes Yes 

Play video/audio in HDD Yes Yes Yes Yes 

Print out / snapshot Yes Yes Yes Yes 

Display GPS information Yes Yes Yes Yes 

Display POS information Yes Yes Yes Yes 

Hyper electronics map Yes Yes Yes Yes 

Display     

Multi-lingual Yes Yes Yes Yes 

Single device view Yes Yes Yes Yes 

Split windows Yes Yes Yes Yes 

Multiple device view Yes Yes Yes Yes 

25/36/49/64 split windows Yes Yes Yes Yes 

Security     

Authentication key Yes Yes Yes Yes 

Password protection Yes Yes Yes Yes 

Web server     

Built-in Apache server -- -- -- Yes 

Logon from DVR -- -- -- Yes 

Logon from the other PC -- -- -- Yes 

Ports used 67, 68 67, 68 67, 68 67, 68, 80 
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Appendix B – Predefined Action Buttons 
 
The predefined Action buttons are divided into several groups as described below: 
 
 Generic buttons 

. (Blank) – No action at all, used to display the specified image file at the predefined 
location. 

. Audio In – Toggle type (Icon), same as View → Audio In, used to enable/mute the 
audio input (Mic. In & Line In) from the PC.  If enabled, the audio input from the PC 
will be sent to the connected device containing the focus object. 

. Audio Out – Toggle type (Icon), same as View → Audio Out, used to enable/mute the 
audio output from the camera for the focus window. 

. Audio Broadcast – Toggle type (Icon), same as View → Audio Broadcast, used to 
enable/disable audio broadcasting from the PC to all the connected devices. 

. Freeze – non-Toggle type (Icon), same as View → Freeze, used to freeze/unfreeze the 
video for all the cameras. 

. Mirror – Toggle type (Icon), same as View → Mirror, used to mirror, flip, or rotate 
180 degrees for the video. 

. Digital Zoom – Toggle type (Icon), same as View → Digital Zoom, used to zoom in the 
video. While enabled, click in the video for 2X, then 4X, and right click to back to 1X. 

. Mode – non-Toggle type (Icon), same as View → Playback, used to change the mode, 
live or playback, for all the cameras. 

. SEQ – Toggle type (Icon), same as View → SEQ Mode / Cameras, used to switch 
to/from the SEQ mode of all the camera objects with SEQ settings in the HEM map. 

. GPS Display – Toggle type (Icon), same as Object → GPS Display, used to display the 
GPS information (if any) for the device for the focus camera. 

. Google Maps – Toggle type (Icon), same as View → Google Maps, used to call up 
Google Maps. 

. Google Maps – Non-toggle type (Window), the window will display Google Maps 
directly. In this mode, right-click on the device's location in Google Maps to display 
the device's video. 

. POS Display – Toggle type (Icon), same as Object → POS Display, used to display the 
POS information (if any) for the device for the focus camera. 

. Snapshot – Toggle type (Icon), same as Object → Snapshot, used to snapshot the 
video for the focus camera. 

. Device Information – Toggle type (Icon), similar to Tools → Device → Config, used to 
display the device information. 
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 Player buttons - Toggle type (Icon) 

. Copy – same as Player → Copy, Copy button in Player Panel, used to call up Copy 
dialog. 

. Fast Backward – same as Player → Fast Backward, Fast Backward button in Player 
Panel. 

. Fast Forward – same as Player → Fast Forward, Fast Forward button in Player Panel. 

. Pause – same as Player → Pause, Pause button in Player Panel. 

. Play – same as Player → Play, Play button in Player Panel. 

. Play/Pause – Play/Pause button in Player Panel. 

. Step Forward – same as Player → Single Step, Step Forward button in Player Panel. 

. Stop – same as Player → Stop, Stop button in Player Panel. 

 
 PTZ buttons – Toggle type (Icon) 

. PTZ Up / PTZ Down – to tilt the focus camera up/down if it’s a PTZ camera. 

. PTZ Left / PTZ Right – to pan the focus camera left/right if it’s a PTZ camera. 

. PTZ Focus + / - – to set the focus of the focus camera far/near if it’s a PTZ camera. 

. PTZ Iris + / - – to increase/decrease the iris of the focus camera if it’s a PTZ camera. 

. PTZ Zoom + / - – to zoom in/out the focus camera if it’s a PTZ camera. 

. PTZ Goto/Set Preset – same as PTZ → Goto preset/Set preset, to goto/set the preset 
position of the focus camera if it’s a PTZ camera. 

. PTZ AutoPAN.Run / AutoPAN.Stop – same as PTZ → Auto PAN → Run/Stop, to 
run/stop the AutoPAN mode of the focus camera if it’s a PTZ camera. 

. PTZ AutoPAN.Set Start Position / AutoPAN.Set End Position – same as PTZ → Set 
start/Set end, to set the Start/End position of the AutoPAN mode of the focus 
camera if it’s a PTZ camera. 

. PTZ SEQ.Run / SEQ.Stop – same as PTZ → SEQ → Run/Stop, to run/stop the SEQ 
mode of the focus camera if it’s a PTZ camera. 

 
 Dialog-Call buttons – Toggle type (Icon) 

. Device Config – same as Tools → Device → Config, used to call up Device List dialog. 

. Software Upgrade – same as Tools → Device → Software Upgrade, used to call up 
Software Upgrade dialog. 

. PTZ Panel – same as View → PTZ Panel, used to call up PTZ Panel (default as 
PTZ.hem). 

. Search By Event – same as Search → Event, used to call up Search-by-event dialog. 

. Search By Time – same as Search → Time, used to call up Search-by-time dialog. 
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. Search PC Video – same as Search → PC video, used to call up Search-PC-video 
dialog. 

. POS Search – same as Search → POS, used to call up POS-Search dialog. 

. GPS Config – same as Object → GPS Config, used to call up GPS Configuration dialog. 

. POS Config – same as Object → POS Config, used to call up POS Configuration dialog. 

. Backup – same as Tools → Backup, used to call up Backup dialog. 
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